Discussion:
swf et win10 ?
(trop ancien pour répondre)
AlainL
2016-04-30 15:30:34 UTC
Permalink
Raw Message
Bonjour,
Mon vieux site affichait jusqu'à présent un diaporama automatique sur sa
page d'accueil. J'avais récupéré un bout de script en flash, facile à
mettre en place et dont je pouvais rapidement actualiser les images.
Il s'affiche encore sur mes machines avec XP et Vista mais semble
fâché avec le W10 tout neuf (avec lequel je galère pas mal :-(( ). A la
connexion la page s'ouvre normalement mais le diapo ne part pas.

autourdalos.fr/html/accueil.php

Je cherche donc un script simple en JS qui ferait le même effet.
Avez-vous ça dans vos tiroirs ?
Merci

alainL
DV
2016-04-30 16:06:43 UTC
Permalink
Raw Message
Post by AlainL
Mon vieux site affichait jusqu'à présent un diaporama automatique sur sa
page d'accueil. J'avais récupéré un bout de script en flash, facile à
mettre en place et dont je pouvais rapidement actualiser les images.
Il s'affiche encore sur mes machines avec XP et Vista mais semble
fâché avec le W10 tout neuf (avec lequel je galère pas mal :-(( ). A la
connexion la page s'ouvre normalement mais le diapo ne part pas.
autourdalos.fr/html/accueil.php
Aucun souci sur mon Windows 10 : ton diaporama s'affiche aussi bien dans
Edge que dans Internet Explorer ou dans Firefox. Il faudrait vérifier ce
qui cloche sur ta machine. Pour commencer, Flash Player est-il bien
installé ? Si c'est le cas, tu dois avoir une entrée "Flash Player" dans
le Panneau de configuration.
--
DV
AlainL
2016-04-30 17:17:59 UTC
Permalink
Raw Message
Post by DV
Post by AlainL
Mon vieux site affichait jusqu'à présent un diaporama automatique sur sa
page d'accueil. J'avais récupéré un bout de script en flash, facile à
mettre en place et dont je pouvais rapidement actualiser les images.
Il s'affiche encore sur mes machines avec XP et Vista mais semble
fâché avec le W10 tout neuf (avec lequel je galère pas mal :-(( ). A la
connexion la page s'ouvre normalement mais le diapo ne part pas.
autourdalos.fr/html/accueil.php
Aucun souci sur mon Windows 10 : ton diaporama s'affiche aussi bien dans
Edge que dans Internet Explorer ou dans Firefox. Il faudrait vérifier ce
qui cloche sur ta machine. Pour commencer, Flash Player est-il bien
installé ? Si c'est le cas, tu dois avoir une entrée "Flash Player" dans
le Panneau de configuration.
Le diapo ne fonctionne pas sous Firefox mais marche avec Chrome.
J'ai un "Flash Player 32bits" dans le panneau de config, c'est normal ça
? Il me semble que W10 est en 64...
DV
2016-04-30 17:30:47 UTC
Permalink
Raw Message
Post by AlainL
Le diapo ne fonctionne pas sous Firefox mais marche avec Chrome.
Dans le gestionnaire de modules de Firefox, catégorie Plugins, vérifie
si le plugin Shockwave Flash est présent et, le cas échéant, s'il est
activé.
Post by AlainL
J'ai un "Flash Player 32bits" dans le panneau de config, c'est normal ça
? Il me semble que W10 est en 64...
J'ignore si c'est normal, mais j'ai exactement la même chose. Et comme
ça fonctionne, je ne m'en soucie pas vraiment. ;-)
--
DV
AlainL
2016-04-30 19:40:26 UTC
Permalink
Raw Message
Post by DV
Post by AlainL
Le diapo ne fonctionne pas sous Firefox mais marche avec Chrome.
Dans le gestionnaire de modules de Firefox, catégorie Plugins, vérifie
si le plugin Shockwave Flash est présent et, le cas échéant, s'il est
activé.
Post by AlainL
J'ai un "Flash Player 32bits" dans le panneau de config, c'est normal ça
? Il me semble que W10 est en 64...
J'ignore si c'est normal, mais j'ai exactement la même chose. Et comme
ça fonctionne, je ne m'en soucie pas vraiment. ;-)
Le plugin en question n'est pas dans la liste des propositions. Où le
trouver ?
DV
2016-04-30 20:03:35 UTC
Permalink
Raw Message
Post by AlainL
Le plugin en question n'est pas dans la liste des propositions. Où le
trouver ?
Je te suggère de réinstaller Flash Player en suivant les consignes
données sur cette page :

<https://support.mozilla.org/fr/kb/installer-plugin-flash-voir-videos-animations-jeux>

(Pense à décocher les deux "offres en option" quand tu seras sur le site
d'Adobe.)

Après ça, normalement, le plugin devrait apparaître dans Firefox.
--
DV
AlainL
2016-05-01 20:42:48 UTC
Permalink
Raw Message
Post by DV
Post by AlainL
Le plugin en question n'est pas dans la liste des propositions. Où le
trouver ?
Je te suggère de réinstaller Flash Player en suivant les consignes
<https://support.mozilla.org/fr/kb/installer-plugin-flash-voir-videos-animations-jeux>
(Pense à décocher les deux "offres en option" quand tu seras sur le site
d'Adobe.)
Après ça, normalement, le plugin devrait apparaître dans Firefox.
C'est bon, flash adobe installé, ça marche. Merci à tous.
alainL

Sergio
2016-05-01 06:20:48 UTC
Permalink
Raw Message
Post by AlainL
Post by DV
Aucun souci sur mon Windows 10 : ton diaporama s'affiche aussi bien dans
Edge que dans Internet Explorer ou dans Firefox. Il faudrait vérifier ce
qui cloche sur ta machine. Pour commencer, Flash Player est-il bien
installé ? Si c'est le cas, tu dois avoir une entrée "Flash Player" dans
le Panneau de configuration.
Le diapo ne fonctionne pas sous Firefox mais marche avec Chrome.
J'ai un "Flash Player 32bits" dans le panneau de config, c'est normal ça ? Il me semble que W10 est en 64...
Normal, les développeurs de Flash ne croient pas au 64 bits...
Sinon: Chrome a son propre Flash intégré. C'est donc Firefox qui n'a pas de plugin Flash. Vérifie (dans Firefox) "Modules" /
"Plugins" que "Shockwave Flash" est là et activé.
--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
christian
2016-05-01 09:10:25 UTC
Permalink
Raw Message
Post by Sergio
Normal, les développeurs de Flash ne croient pas au 64 bits...
ils ne croient peut-être plus en flash non plus :-)

la recherche sur un moteur avec flash+avenir est édifiante
--
Christian
Eric Demeester
2016-05-01 11:26:49 UTC
Permalink
Raw Message
Bonjour,

AlainL (Sat, 30 Apr 2016 17:30:34 +0200 -
Post by AlainL
autourdalos.fr/html/accueil.php
Je cherche donc un script simple en JS qui ferait le même effet.
Avez-vous ça dans vos tiroirs ?
J'ai, entre autre ici :
http://www.pagliaghju-di-cannetu.com/bergerie_jardin.php

C'est basé sur le script 'jquery_cross_slide.js' qui utilise la
bibliothèque jquery.

Tu trouveras les détails en regardant le code source de la page (scripts
diaporama), n'hésite pas à copier-coller si ça te convient.

Il y a aussi un lecteur Flash pour le son, le client tenait à ce qu'il y
ait un fond sonore jouant par défaut, et je tenais à ce que ce soit
désactivable parce que les fonds sonores par défaut m'énervent.

Si je réécrivais ce site aujourd'hui, ce serait en HTML5, j'utiliserais
la balise <audio> pour le son et je n'embarquerais pas de lecteur Flash,
mais c'est une autre histoire :)
Loading...